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PART I
CHAPTER 1

Introduction — Why Excel Matters

"Excel is the closest thing we have to a universal business language."

Welcome. Microsoft Excel is more than a spreadsheet application — it is a superpower waiting to be
unlocked. With over 750 million users worldwide, Excel powers critical business operations in every

industry, from Wall Street financial models to small business inventory tracking.

1.1 Why Excel Dominates Business

Ubiquity & Standardization
* Over 60% of job postings list Excel as a required or preferred skill
* Files open everywhere — xlIsx is a universal standard

* Cross-platform: Windows, macOS; i0S, Android, and Web

Unmatched Flexibility
* 1,048,576 rows x 16,384 columns per worksheet
* 400+ built-in functions covering every calculation need
* VBA for unlimited customization; Power Query for data transformation

* Scales from grocery list to enterprise financial model

Compelling ROI

* Save 5+ hours/week = $13,000+ in annual productivity value
* Free alternatives (LibreOffice, Google Sheets) share the same principles

* Reduce manual errors by 87% with proper formula structure

1.2 The Reality Check: How Most Users Work

Research from Microsoft reveals that the average Excel user only utilizes 10—15% of available features,

manually copy-pastes data for 5+ hours per week, and makes calculation errors approximately 20% of

the time. This book changes that.
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1.3 What This Book Will Transform

Advanced Technical Skills
* Automate repetitive tasks with VBA macros — save 10+ hours/week
* Create dynamic dashboards with slicers, timelines, and KPI cards
» Master advanced lookups: XLOOKUP, INDEX/MATCH, dynamic arrays

* Transform raw data with Power Query and model it with Power Pivot

Professional & Career Benetfits
» Complete tasks 5x faster with keyboard shortcuts and templates
* Produce professional-quality outputs stakeholders trust
* Advanced Excel = 10-20% salary premium in most roles

* Build tools that help your entire team, not just yourself

1.4 The Three Golden Rules of Excel Mastery

Rule 1: Automate Everything Repetitive

Any task you perform more than twice deserves automation. Whether it is formatting reports, importing data, or
running calculations — there is a formula, shortcut, or macro that does it faster, more accurately, and consistently.

Rule 2: Organize Logically from the Start

Clean, structured data is 80% of successful Excel work. Design your data structure before entering formulas.
Use Tables for dynamic ranges, named ranges for key values, and consistent naming conventions throughout.

Rule 3: Visualize for Impact, Not Decoration

Every chart should communicate one clear insight. Use appropriate chart types, include direct labels, eliminate
clutter, and design visuals that make the right decision obvious within 5 seconds of viewing.

1.5 Your Learning Journey

Part[ (Ch. 1-2) Interface mastery, navigation, file management
Part I (Ch. 3-4) Essential formulas through advanced lookups and arrays
Part [l (Ch. 5-6) VBA automation and professional data visualization
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Part [V (Ch. 7-8) Power Query and Power Pivot for enterprise-scale work
Part V (Ch. 9-10) Interactive dashboards and productivity optimization
Part VI (Ch. 11-12) Troubleshooting mastery and real-world projects

1.6 Time Investment & Expected ROI
Foundation (Chapters 1-3): 10-15 hours. Advanced Techniques (4-8): 20-25 hours. Mastery (9-12):
15-20 hours. Total: 45—60 hours over 6—8 weeks. You will begin saving 10+ hours/week within the first

two weeks of applying what you learn.
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PART I
CHAPTER 2

Ada Codewell - Gray Technical, LLC ©2026

Excel Interface & Navigation Mastery

Understanding every element of the Excel interface is your first step to mastery. Power users treat the

Ribbon, Formula Bar, Name Box, and Status Bar as tools — not decoration. This chapter reveals how

professionals use each one.

2.1 The Complete Excel Interface

Title Bar

Ribbon

Formula Bar

Worksheet Grid

Status Bar (Bottom)

Sheet Tabs

Quick Access Toolbar

2.2 Ribbon Tab

Home (68% of usage)

Shows workbook name; Quick Access Toolbar on the left

Tabbed command center — Home, Insert, Page Layout,

Formulas, Data, Review, View, Developer

Shows selected cell content; Name Box (left) for navigation;

Function insert button

Columns A—XFD (16,384) x Rows 1-1,048,576; active cell
highlighted

Average, Count, Sum of selection; calculation status; zoom
slider — right-click to customize

Navigate worksheets; right-click to rename, color-code, move, or
delete

Always visible above Ribbon; add Save, Undo, Format Painter,

Paste Special

Clipboard, Font, Alignment, Number formatting, Cell operations, Find & Select
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Insert (15%)
Tables, Charts (20+ types), Slicers, Timelines, PivotTables, Sparklines

Formulas (8%)

Function Library, Name Manager, Formula Auditing, Calculation options

Data (3%)
Power Query (Get Data), Sort & Filter, Text to Columns, Flash Fill, Data Validation, What-If Analysis

Page Layout (5%)
Themes, Page Setup, Print Area, Scale to Fit, Sheet options

Review (1%)
Comments, Track Changes, Protect Sheet/Workbook, Share

View (1%)

Freeze Panes, Split, Arrange All, Zoom, Macro recording

Developer (advanced)

Enable via File » Options » Customize Ribbon; required for VBA, Form Controls, XML

2.3 Navigation Techniques

Cerl + Arrow Jump to edge of contiguous data region

Ctrl + Shift +
Extend selection to data edge
Arrow

Ctrl + Home / End Go to Al / last used cell

E5 et Ctnl G Go To dialog — jump to any cell, range, or named range

Ctrl + Page
Up/Down Switch between worksheet tabs

Name Box Click and type any address (e.g. Z5000) — press Enter to jump
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» Auto Recover: File » Options » Save — set to every 5 minutes (default is 10). Non-negotiable.

2.6 File Types Reference

xlsx
Standard workbook — no macros; maximum compatibility;
default for most work
Xlsm
Macro-enabled — required whenever you save VBA code; same
as xlsx otherwise
xltx
Template — opens as new unnamed workbook; never
overwrites the master
xltm Macro-enabled template — template + automation combined
xIsb
Binary — 50% faster open/save, smaller files; use for 100k+ row
workbooks
xlam Add-in — loads in background to add custom functions to Excel
.CSV
Plain text, comma-separated — universal data exchange; no

formatting or formulas

2.7 The 6 Most Costly Excel Mistakes

X Hard-coding values in formulas

Fix: Use cell references (FA1*$B$1) instead of constants (=A1%0.0825). One cell to update vs. hundreds.

X Merge & Center for titles
Fix: Use Format Cells » Alignment » Center Across Selection instead. Merged cells break sorting, filtering,

and most formulas.

X Not using Tables (Ctrl+T)
Fix: Tables auto-expand when new rows are added, use readable structured references like

Sales[Amount], and integrate perfectly with PivotTables and Power Query.
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Formulas & Functions

From essential calculations to advanced lookups and arrays
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PART Il
CHAPTER 3

Essential Formulas & Functions

Every Excel formula starts with = and follows a consistent logic: function name, opening parenthesis,
arguments, closing parenthesis. Master this chapter and vou will be able to solve 90% of everyday data

problems without VBA.

3.1 Formula Fundamentals
Basic syntax: =FUNCTION NAME(argumentl
argument2, __.)

Complete anatomy example:
=SUM(B2:B100) * 1.08 + 500

mm Function mm Range mm Constant mm Constant

Arguments can be:

Cell references - Al_, B2:C10, Sheet2!Al
Constants : 5, "Text"_, TRUE, FALSE
Named ranges : SalesData, TaxRate
Nested formulas : =ROUND(CA1*Bl. 2)
Arrays : {1.2.3:4.5.6}

3.2 Cell References — The Most Important Concept

Relative Reference

Adjusts automatically when copied. The default.

Example: =A1*B1 — becomes =A2*B2 when copied down

Absolute Reference ($)
Locked — never changes when copied. Press F4 to toggle.

Example: =$BS1*¥A2 — Bl stays fixed; A2 adjusts

Mixed Reference

One dimension locked, one relative.

Example: =$B1 (column locked) or =B$1 (row locked)

e [
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3D Reference

Refers across multiple worksheets.

Example: =SUM(Jan:Dec!B5) — sums B5 firom Jan through Dec

3.3 Mathematical & Statistical Functions

SUM(range) Add all values in range

SUMIF(range.criteria_sum r

Conditional sum — one criterion
ange)

SUMIFS(sum.rl_cl._r2_c2_..) Conditional sum — multiple criteria

AVERAGE / AVERAGEIFS Mean value, with optional criteria
COUNT/COUNTA/COUNTBLANK Count numbers / non-blanks / blanks

COUNTIF / COUNTIFS Count cells matching criteria

MAXIFS / MINIFS Max/min value matching criteria (Excel 2019+)
SUMPRODUCT Multiply arrays then sum — works in all versions
ROUND(val. digits) Round to specified decimal places

ABS / SIGN / MOD Absolute value / sign / remainder

3.4 Logical Functions

IF
Syntax: =IF(test, true val_, false val)
Example: =IF(A1>=70, "Pass"_, "Fail'")

The foundation of conditional logic. Nest up to 64 [Fs for tiers.

IFS

Syntax: =IFS(testl, vall, test2, val2, ..., TRUE, default)
Example: —TES(Al=—90_"A"_Al=80_"BM Al>—70_"C!'_TRUE_"E")

Cleaner than nested IFs for 3+ conditions.
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PART Il
CHAPTER 4

Advanced Formulas — Lookup, Array & Text
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VSTACK / HSTACK
Example: =VSTACK(TableA, TableB)

Ada Codewell - Gray Technical, LLC

Stack multiple ranges vertically or horizontally — live, without copy-paste.

4.3 Text Functions Mastery

TEXTJOIN(delim_, ignore_ ..)

CONCAT(range)

LEFT(text, n)/RIGHT(text. n)

MID(text_, start. n)
LEN(text)

TRIM(text)

CLEAN( text)

UPPER / LOWER / PROPER
SUBSTITUTE(text, old. new)
TEXT(value_, format)

FIND / SEARCH

VALUE( text)

Join text with delimiter, optionally skip blanks

Merge a range of cells into one string

Extract n characters from start or end

Extract n characters starting at position

Count characters

Remove leading, trailing, and extra internal spaces

Remove non-printable characters
(common imported data)

Case conversion: ALL CAPS / all lower / Title Case

Replace every occurrence of old text with new

Format a number as text: =TEXT(A1,"$#,##0.00")

Find position (FIND=case sensitive, SEARCH=not)

Convert text-number to real number
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Automation & Visualization

VBA macros and professional chart design
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PART III
CHAPTER 5

VBA Automation & Macros
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(Gsel == [ Show/hide Project Explorer
Ctrl + G Show/hide Immediate Window (test code here)
|5 Open Object Browser — browse all objects, methods, properties

Key VBE panes: Project Explorer (file/sheet tree), Code Window (write here), Properties Window (F4),

Immediate Window (Ctrl+G for one-liner testing).

Critical: Files with VBA must be saved as xlsm. Saving as .xIsx silently deletes all code.

5.3 Recording a Macro
1. Enable Developer tab: File » Options » Customize Ribbon » check Developer
. Developer tab » Record Macro
. Name it descriptively (no spaces): FormatMonthlyReport
. Optionally assign Ctrl+Shifttkey shortcut
. Perform your actions in Excel exactly as you want them automated

. Developer tab » Stop Recording

~N N R W N

- Alt+F11 to review and clean up the generated code

5.4 VBA Code Examples

Auto-Backup with Timestamp
Sub AutoBackup()
Dim src As String., bak As String src =
ActiveWorkbook_FullName bak = Replace(src, "_xlsx'",
" backup " & Format(Now., "YYYYMMDD HHNN") &
" _x1Isx'")
ActiveWorkbook_SaveCopyAs bak MsgBox
"Backup saved: " & bak, vbInformation
End Sub

Export All Sheets as Separate PDF's
Sub ExportSheetsPDF()
Dim ws As Worksheet
Dim folder As String
folder = ThisWorkbook_Path & "\\"
Application.ScreenUpdating = False
For Each ws In ThisWorkbook.Worksheets
ws _ExportAsFixedFormat Type:=x1TypePDF,
Filename:=folder & ws_Name & "_pdf", _

., | -
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Quality:=x1QualityStandard

Next ws

Application.ScreenUpdating = True

MsgBox '"All sheets exported to: " & folder

End Sub

Clean & Format Data on Import

Sub CleanImportedData()

Dim ws As Worksheet Dim rng As Range. cell As Range
Set ws = ActiveSheet

Application.ScreenUpdating = False
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PART III
CHAPTER 6

Data Visualization & Professional Charts

Effective data visualization transforms numbers into decisions. A well-designed chart communicates its

insight within 5 seconds. This chapter covers every chart type, professional formatting principles, and

dashboard design from blank canvas to boardroom-ready.

6.1 Choosing the Right Chart Type

Column / Bar

Line

Area

Pie / Doughnut

Scatter

Bubble

Histogram

Box & Whisker

Waterfall

Combo

Compare categories; column=vertical, bar=horizontal (better for long
names)

Trends over time — stock prices, monthly sales, temperature

Cumulative volume over time; stacked area shows composition

Parts of a whole — max 5 slices; label directly, avoid legends

Correlation between two numeric variables; reveal outliers

3D scatter — X, Y position plus bubble size for a third variable

Frequency distribution — automatically bins continuous data

Data spread: median, quartiles, min, max, outliers

Running total with +/- contributions — P&L;, budget variance

Two types on one chart — e.g. columns (revenue) + line (margin %)
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Advanced Data Tools

Power Query and Power Pivot for enterprise-scale work
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PART IV
CHAPTER 7

Power Query & Data Transformation
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7.3 Core Power Query Transformations

Remove Rows Blank rows, errors, duplicates, top/bottom N rows

Change Type Right-click column header — crucial for dates and numbers

Replace Values

Find and replace within a column
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7.5 Real-World Power Query Examples
Combine 12 Monthly CSV Files Automatically

Data » Get Data > From Folder. Point to the folder containing vour monthly files. Power Query reads all
files matching the pattern, combines them into one table, and adds a Source Name column so you know

which file each row came from. Drop new files into the folder and click Refresh.

Fix Inconsistent Date Formats
Change column type to Date. If it fails, add a Custom Column: Date From(Text.Range([DateCol], 0, 10)).

Then remove the original.

Unpivot Monthly Columns into Rows
Select the identifier columns (Name, Category), then Transform > Unpivot Other Columns. Months

become rows — ideal for PivotTable analysis.

Merge Sales + Customers Tables
Home » Merge Queries. Select CustomerID from each table. Choose Left Outer join to keep all sales

rows. Expand the merged column to pull in customer details.

7.6 Troubleshooting Power Query Errors

Error Cause Solution

Type Column contains mixed types (text Right-click » Change Type » Using

mismatch + numbers) locale

Source not File path has changed or file is Data » Queries & Connections » Edit »

found moved Change Source

Out of . Add filter steps early — filter rows
Too much data loaded before filtering ;

memory before expanding columns

Query Custom  column breaks SQL Move breaking steps to end of query

folding push-down to database sequence
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PART IV
CHAPTER 8

Power Pivot & Data Models
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8.5 Common DAX Patterns

Running total

Moving average

Market share

Rank

% of total

CALCULATE([Total Sales], DATESYTD(Dates[Date]))

AVERAGEX(DATESINPERIOD(Dates[Date], LASTDATE(Dates[D
ate]),-90,DAY), [Total Sales])

DIVIDE([Category Sales], CALCULATE([Total Sales],
ALL(Products[Category])))

RANKX(ALL(Products[Name]), [Total Sales])

DIVIDE([Measure|, CALCULATE([Measure], ALL(table)))



Dashboards & Productivity

Interactive reporting and time-saving techniques
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PART V
CHAPTER 9

Interactive Dashboards & Reporting

A great dashboard answers business questions before they are asked. This chapter takes you from
design principles through eight complete dashboard templates, to professional export techniques for

presentations and reports.

9.1 The 3 Golden Rules of Dashboard Design

1. Answer Questions, Don't Just Display Data

Every element should answer a specific business question. 'What are our top 5 products by revenue this quarter?" is
actionable. 'Here is all our product data' is not.

2. The 5-Second Test

A stakeholder should grasp the dashboard's key message within 5 seconds. Achieve this with clear visual hierarchy,
minimal cognitive load, and prominent KPIs.

3. Design for Your Audience

Executives want high-level trends and variances. Managers want department-level performance with drill-down. Analysts
want filtering and data manipulation. Operations teams want real-time status and alerts.

9.2 Dashboard Layout Framework
Recommended Layout:
EEEEE SIS NN NN
m TITLE + TIME PERTIOD + FILTERS m Level 1: Context
EEEEE SIS NN NN
m KPT 1 m KPT 2 m KPT 3 m KPT 4 m Level 2: Key Metrics
N N N
m m m Level 3: Primary Charts
m MAIN TREND CHART m SECONDARY BREAKDOWN m
C B
EEEEE SIS NSNS NN
m DETATL TABLE m SUPPORTING CHART m Level 4: Detail
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PART V
CHAPTER 10

Productivity Hacks & Time-Saving Techniques

The difference between Excel novices and power users is rarely obscure feature knowledge — it is the
consistent application of high-leverage habits. This chapter covers the shortcuts, techniques, and

workflows that professionals use every single day.

10.1 100 Essential Keyboard Shortcuts

Navigation & Selection

Ctrl + Arrow Jump to edge of data region

Ctrl + Shift +
Arrow Select to data edge

Ctrl + Home / End Jump to Al / last used cell

Ctrl + Page

Up/Down Switch worksheets
F5 / Ctrl + G Go To dialog
Al T
{scmiculion) Select visible cells only
Ctrl + A Select region, then all
Ctrl + Space Select entire column
Shift + Space Select entire row

Editing & Formatting

Ctrl + D / R Fill down / fill right

Ctrl + 1 Format Cells dialog

e
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Monthly report

Data cleaning

Error rate

Team of 5 savings

- Gray Technical, LLC

Before: 2 hours. After: 15 minutes. (88% reduction)
Before: 90 minutes. After: 5 minutes with Power Query.
Before: 15% errors. After: 2% with validation. (87% reduction)

10 hrs/person/week x 5 people = 50 hrs/week = 2,600 hrs/year

e G



Troubleshooting & Mastery

Diagnose any issue and apply skills to real projects
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PART VI
CHAPTER 11

Troubleshooting & Error Handling

The best Excel experts are not those who never encounter errors — they are those who diagnose and

fix them fastest. This chapter gives you a systematic toolkit for every class of Excel problem.

11.1 Formula Error Reference

H#NAME? ) ) )
Typo in function name or undefined Check spellng; verify name in
named range Formulas » Name Manager

H#N/A
Lookup value not found in search Use IFERROR or XLOOKUP's
range [if not found] argument

H#REF !

Formula references deleted/invalid Check for deleted rows/columns:
cell rebuild reference

#DIV/0! =IFERROR(A/B,0) or =IF(B=0,0,A/B)
Division by zero  or

empty denominator

#VALUE!

Wrong data type — text where Use VALUE() or DATEVALUE(); check
number expected for text-numbers

#NULL!

Invalid range intersection (missing Replace space operator with comma or
colon) colon

#NUM!

Numeric result too large/small; no Check inputs; SQRT of negative, IRR
solution exists with no solution
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Problem: Code works in testing but fails in production

Solution: Check for hardcoded sheet names, absolute file paths, or assumptions about column

positions. Parameterize everything.

11.6 Prevention Strategies
* Always work on a copy of source data — never transform the original
» Use data validation to prevent bad input before it enters the workbook
» Name all key ranges and Tables — makes formulas self-documenting
* Document complex formulas with a comment cell or Name Manager description
* Set AutoRecover to every 5 minutes: File » Options » Save
* Keep a ARCHIVE folder and save dated snapshots before major changes

* Run Formulas » Error Checking before sharing any workbook

i
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PART VI
CHAPTER 12

Real-World Case Studies & Projects

Theory becomes mastery through application. This chapter presents four complete, real-world projects
that synthesize everything from Parts I-VI. Work through each one, and yvou will have a professional

portfolio demonstrating your full Excel capability.

12.1 Project 1: Financial Dashboard

Build a complete monthly financial dashboard that tracks revenue, expenses, and profit by department,

with year-over-year comparison and trend analysis.

What You Will Build
* Automated data import via Power Query from CSV exports
* DAX measures for Revenue, Expenses, Gross Profit, and YoY Growth %
* KPI score cards with conditional formatting (green/red vs. budget)
* Line chart: 12-month revenue trend with prior year overlay
» Waterfall chart: budget variance by department

* Slicer-driven filtering by department, month, and account type

Key Skills Applied
Power Query (import & clean), Power Pivot (data model + DAX), PivotTables, Slicers, Combo Charts,

Conditional Formatting, Sheet Protection.

12.2 Project 2: Sales Performance Tracker

Create an automated sales tracking system with territory management, quota tracking, commission

calculation, and an interactive leaderboard.

+ XLOOKUP to pull rep details and territory assignments from a lookup table
* Commission calculator using tiered IF formula

* Dynamic leaderboard using LARGE and INDEX/MATCH

[, T
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* Conditional formatting to highlight reps above/below quota
* Sparklines in the data table for instant trend context

* Protected mput form with data validation drop-downs

12.3 Project 3: Inventory Management System

Design a functional inventory system that tracks stock levels, triggers reorder alerts, calculates days of

supply, and generates purchase orders automatically via VBA.

* Structured Table with COUNTIFS for stock level monitoring
* Conditional formatting rules: red (critical), yellow (low), green (healthy)
* [FERROR-wrapped lookups for supplier details

* Automated PO generation VBA macro that creates a new sheet, fills in order details, and saves as
PDF

* Power Query connection to refresh stock data from CSV export

12.4 Project 4: Automated Monthly Report

The ultimate productivity project: a workbook that imports this month's data, cleans it, updates all
calculations, refreshes charts, and exports a professional PDF — all from one macro button.

Sub RunMonthlyReport()
Application.ScreenUpdating = False

Application.Calculation = x1Manual

* Step 1: Refresh all Power Query connections
ActiveWorkbook.RefreshAll

* Step 2: Update the report date
Sheets("Dashboard")_[Bl] = Format(Date, "MMMM YYYY'™)

* Step 3: Recalculate
Application.Calculation = xlAutomatic

Application._Calculate

* Step 4: Export to PDF Dim fin As String fh =
ThisWorkbook _Path & "\\" &  Format(Date,

"YYYY-MM'") & " Monthly Report.pdf”
Sheets("Dashboard") _ExportAsFixedFormat x1TypePDF, fn

Application.ScreenUpdating = True MsgBox "Report exported: " & fn,

vbInformation
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End Sub

Add a button to your Dashboard sheet (Developer » Insert » Button), assign this macro, and your monthly

report process becomes a single click.
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APPENDIX
CHAPTER A&

Resources, Reference & Quick Guides

A.1 Gray Technical Product Downloads

Excel Mastery Guide (this book) www_graytechnical com/excel-mastery/
VBA Template Pack www_graytechnical com/vba-template-pack/
Data Scraper Tool www_graytechnical com/data-scraper/

XYZ Mesh www_graytechnical com/xyz-mesh/

Excel Draw www.graytechnical.com/exceldraw/

DXF Reader GT www_graytechnical com/dxf reader gt/
Ultimate Excel Cheat Sheet www_graytechnical com/excel-cheat-sheet/
PDF Printables Bundle www_graytechnical com/printables/

A.2 Formula Quick Reference

SUM / SUMIFS Sum with 0 or multiple conditions

AVERAGE / AVERAGEIEFS Mean with conditions

CQUNT / COUNTIFES Count numbers / with conditions

COUNTA / COUNTBLANK Count non-empty / empty cells

MAXIFS / MINIFS Max/min matching criteria (2019+)
IF / IFS Conditional logic
IFERROR / IFNA Suppress errors

B {, T
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XLOOKUP

INDEX / MATCH
VLOOKUP / HLOOKUP
FILTER

SORT / SORTBY

UNIQUE
SEQUENCE
TEXTJOIN
TEXT
TRIM / CLEAN
NETWORKDAYS
DATEDIF

SUMPRODUCT

Microsoft Learn

ExcelJet.net

Chandoo.org

MrExcel Forum

Excel Off The Grid

SQLBI/ DAX.guide

Ada Codewell - Gray Technical, LLC

Modern lookup — any direction

Classic lookup — all Excel versions
Legacy lookups — look right/down only
Return rows matching condition (365+)

Dynamic sorted view (365+)

Extract distinct values (365+)

Generate number arrays (365+)

Join text with delimiter

Format number as string

Remove spaces / non-printable chars
Working days between two dates
Age or tenure calculation

Conditional math, all versions

A.3 Recommended External Resources

learn.microsoft.com/en-us/office/excel — official documentation
and tutorials

Function examples, formula walkthroughs, and shortcut library

Dashboards, charts, and practical tutorials

mrexcel. com — active community for formula and VBA help

Power Query, dynamic arrays, and automation deep dives

Power Pivot and DAX reference — best DAX learning resource



EXCEL MASTERY GUIDE — VERSION 2.0 Ada Codewell - Gray Technical, LLC &

Leila Gharani (YouTube)
Highly accessible advanced Excel and Power Query video

tutorials

Chandoo YouTube Chandoo.org channel — dashboards, macros, and tips

A.4 Contact & Support

Website www_graytechnical com
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Happy Exceling! — Ada Codewell, Gray Technical, LL.C

Automate - Analyze - Visualize - Master - Innovate






