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1. What Is Ollama AI Assistant?
Ollama AI Assistant is a Visual Studio extension that embeds a complete AI coding assistant directly inside your IDE. It connects to any AI provider you choose and gives you an intelligent assistant that understands your code, answers questions, generates functions, finds bugs, reviews your work, and helps you write better software faster.
The extension works with Visual Studio 2022 Community, Professional, and Enterprise on Windows 10 and Windows 11. When used with a local Ollama server, it requires no internet connection and your code never leaves your machine.
1.1 Edition Overview
Ollama AI Assistant comes in three editions. All editions use the same interface and connect to the same AI providers. The editions differ in which features are available.
Free Edition — Core AI chat and coding assistance with a response length limit. All AI providers included.
Personal Edition — Everything in Free with unlimited response length plus power tools for individual developers.
Pro Edition — Everything in Personal plus documentation generation, team shared memory, Data Chunker Pro integration, and solution-wide analysis.
NOTE  Features marked PERSONAL & PRO are available in both paid editions. Features marked PRO ONLY require the Pro edition. The DCP button for Data Chunker Pro integration is available on all editions.
2. Setup and Configuration
2.1 Installation
Run the installer for your edition. It automatically installs the extension into Visual Studio. When installation is complete, restart Visual Studio. To confirm installation go to Extensions > Manage Extensions and search for Ollama AI Assistant.
2.2 Connecting to an AI Provider
Go to Tools > Options > Ollama AI > Provider to configure your connection. You can switch providers any time without reinstalling.
	Provider
	Description

	Ollama
	Local or network Ollama server. No API key needed. Runs on your own hardware. Code never leaves your machine or network.

	OpenAI
	ChatGPT and GPT-4 via api.openai.com. Requires an OpenAI API key.

	Anthropic
	Claude models via api.anthropic.com. Requires an Anthropic API key.

	OpenAI-Compatible
	Any server using the OpenAI API format: LM Studio, Jan, Groq, Azure OpenAI, Together AI, Mistral AI, and others.



Ollama Setup
Set AI Provider to Ollama.
Set Server URL to your Ollama server address.
http://localhost:11434          (Ollama on this machine)
http://192.168.1.100:11434      (Ollama on another machine)
Set Model Name to the exact name shown by ollama list on the server.
Leave API Key blank. Click OK.
OpenAI Setup
Set AI Provider to OpenAI.
Paste your OpenAI API key. Set Model Name, for example: gpt-4o.
Click OK.
Anthropic (Claude) Setup
Set AI Provider to Anthropic.
Paste your Anthropic API key. Set Model Name, for example: claude-sonnet-4-5.
Click OK.
OpenAI-Compatible Setup
Set AI Provider to OpenAI-Compatible.
Set Server URL to the base URL of your server, for example:
http://localhost:1234/v1        (LM Studio)
http://localhost:11434/v1       (Ollama OpenAI-compatible mode)
Set API Key if your server requires one. Set Model Name. Click OK.
2.3 Opening the Chat Panel
Go to View > Ollama AI Assistant. The panel opens as a dockable window inside Visual Studio. Dock it to the right side or float it anywhere. A green dot means the server is connected. A red dot means it cannot be reached.
3. The Chat Panel
3.1 Sending Messages
Type your question or request in the input box at the bottom and press Enter to send. Press Shift+Enter to add a new line without sending. Responses stream back in real time. All text in a response is selectable — click and drag to select, then Ctrl+C to copy.
NOTE  Free Edition responses are limited to 30 lines of generated text. Personal and Pro have no response length limit.
3.2 Context Bar
	Control
	Behaviour

	File checkbox
	When checked, the currently open file is included with every message.

	Selection active
	Appears when code is highlighted. Only the selection is sent, not the whole file.

	+ Solution Context
	Reads all source files in your solution and injects them into the input.



3.3 Header Controls
	Control
	Function

	Status dot
	Green = connected. Red = server unreachable.

	Model dropdown
	Switch between AI models instantly without opening settings.

	New Chat
	Clear conversation history and start fresh.

	Settings (gear)
	Open Tools > Options > Ollama AI directly.

	Stop
	Cancel a response that is currently generating.

	Git
	Generate commit messages and summarize recent changes.

	Fix Errors
	Send current Visual Studio build errors to the AI.

	Memory
	View or add notes to the project memory bank.

	History
	Browse and reload previous chat sessions for this project.

	DCP
	Load a Data Chunker Pro export for enhanced AI context. Available on all editions.



3.4 Inserting AI Code Into Your Editor
When the AI responds with a code block, an Insert Code at Cursor button appears below the response. Clicking it opens the Diff View window where you can review exactly what will change before anything is written to your files.
4. Diff View — Review Before Applying
Every time the AI suggests code to insert, the Diff View window opens first. The left panel shows your original code and the right panel shows the proposed code. Green highlights additions and red highlights removals. Both panels scroll together.
	Button
	Action

	Accept All
	Apply the proposed code at the cursor position.

	Apply to Selection
	Replace only your currently selected text.

	Reject
	Close without making any changes.



WARNING  Always read the diff before accepting. Reject is always safe.
5. Inline Code Completion
AI completions appear in the standard Visual Studio completion list prefixed with [AI] and sorted to the top. They are generated by your AI model based on the code surrounding your cursor.
	Trigger
	When

	Typing pause
	Stop typing for half a second. Completions appear automatically.

	Ctrl+Space
	Invoke explicitly at any time.



Press Tab or Enter to accept. Press Escape to dismiss. The first [AI] item is the full suggestion. Additional items show individual lines of multi-line suggestions.
TIP  Write a comment describing what you want before invoking completion. The AI reads the comment as intent and generates matching code.
6. Right-Click Code Editor Menu
Select code in the editor and right-click to access AI actions without switching to the chat panel.
	Menu Item
	What It Does

	Ask Ollama: Explain Selection
	Explains what the selected code does in plain English.

	Ask Ollama: Detailed Explanation
	Full analysis of purpose, inputs, outputs, and edge cases.

	Ask Ollama: Generate Function
	Generates a new function based on the current code context.

	Ask Ollama: Find Bugs
	Scans the selection for bugs, null references, and edge cases.

	Ask Ollama: Generate Tests [Personal+]
	Generates a complete unit test class for the selection.

	Ask Ollama: Review Code [Personal+]
	AI code review categorized by severity.

	Ask Ollama: Refactor Analysis [Personal+]
	Produces concrete refactoring proposals with before/after code.

	Ask Ollama: Generate Docs [Pro]
	Generates XML documentation comments for the selection.



7. Data Chunker Pro Integration
NOTE  The DCP button is available on all editions — Free, Personal, and Pro.
7.1 What Is Data Chunker Pro?
Data Chunker Pro is a separate Gray Technical product that converts any file into AI-ready knowledge. It supports over 800 file formats including compiled binaries (.exe, .dll), legacy code (COBOL, FORTRAN), all major programming languages, Office documents, PDFs, CAD files, and more.
What makes it unique is Binary Intelligence — the ability to extract meaningful information from compiled executable files with no access to the source code. It can read a compiled .exe and extract user-facing strings, framework dependencies, function names, and structural information that the AI can then reason about.
Data Chunker Pro runs entirely offline on your Windows machine. No files are uploaded. No internet connection is required. Your data never leaves your network.
7.2 How the Integration Works
When you export a project with Data Chunker Pro, it creates a structured export folder containing an index file and individual chunk files — one per code block, function, class, or document section. Ollama AI Assistant can load that export folder and use it as a knowledge base.
Once loaded, the extension automatically searches the chunks for content relevant to every message you send and injects the most relevant chunks as context alongside your message. The AI sees both your current file and the pre-indexed knowledge from the Data Chunker Pro export.
The vector search uses TF-IDF scoring — a proven information retrieval technique that weights terms by how specific and important they are across the entire knowledge base. This means a question about a specific class or method will surface the most relevant chunks even if the exact words differ slightly.
7.3 What a Data Chunker Pro Export Contains
When Data Chunker Pro exports a project it creates the following structure:
exportFolder\
    index.json              <- metadata for every chunk
    index.md                <- human-readable index
    index.txt               <- plain text index
    [ProjectName].json      <- full project manifest
    Contents_[name]\        <- individual chunk .txt files
    vectored_database\      <- TF-IDF vector index (if built)
        vocabulary.json
        vectors.json
        filepaths.json
7.4 Loading a Data Chunker Pro Export
Run Data Chunker Pro on your codebase or any files you want the AI to know about.
Export the results to any folder on your machine.
In Visual Studio, click the DCP button in the chat panel header.
Browse to the export folder — the folder containing index.json.
The extension loads all chunk files and builds a search index.
The DCP button updates to show DCP (170) indicating chunks loaded.
Every message now automatically injects the most relevant chunks as context.
TIP  Use Context-Aware chunking in Data Chunker Pro for the best results. It preserves function boundaries, imports, and dependencies so the AI gets complete context rather than fragments.
7.5 Managing the Loaded Export
Click the DCP button while an export is loaded to see its status — how many chunks are loaded and which folder they came from. From that dialog you can load a different export or unload the current one.
Set a default export path in Tools > Options > Ollama AI > Data Chunker Pro so the same export loads automatically every time you open Visual Studio.
7.6 Why This Matters
Without Data Chunker Pro, the AI only knows about what is currently open in your editor and whatever your built-in RAG index has scanned. For large projects, legacy codebases, or projects with compiled dependencies, that is a significant limitation.
With a Data Chunker Pro export loaded, the AI has deep knowledge of your entire codebase before you ask the first question — including code that has never been opened in the editor, binary files with no source, and legacy formats that Visual Studio cannot parse.
	Scenario
	Benefit

	Large codebase
	AI knows all 500 files, not just the 3 currently open

	Compiled dependency (no source)
	AI knows what the DLL does from binary analysis

	Legacy COBOL or FORTRAN
	AI understands code VS cannot parse at all

	New team member
	AI explains any part of the codebase on demand

	Undocumented legacy system
	AI can describe what code does from binary extraction



8. Memory Bank
The Memory Bank gives the AI persistent knowledge of your project that builds over time. Each project has its own memory file. The AI reads this file before every conversation so it already knows your codebase before you ask your first question.
8.1 How It Updates
The memory bank updates automatically every time you close a solution. The extension scans all source files, extracts summaries of every class, module, method, and function, and writes them to a markdown file at:
%AppData%\OllamaVS\Memory\[ProjectName].md
8.2 Adding Manual Notes
Click the Memory button in the chat panel header and select Add Note to append anything you want the AI to always know — architectural decisions, known issues, coding conventions, or anything not obvious from reading the source code.
8.3 Team Shared Memory Bank
PRO ONLY  Team shared memory lets all developers on a team share the same AI project knowledge.
Option A — Network Share
Go to Tools > Options > Ollama AI > Team Memory.
Set Enable Team Shared Memory to True. Set Storage Type to NetworkPath.
Set Team Network Path to a UNC path accessible to all team members.
\\\\fileserver\\projects\\OllamaMemory
Option B — Git Repository
Set Storage Type to GitRepository.
Set Team Git Memory File to a path relative to the solution root.
.ollama\\memory.md
Commit and push the file after it is first created.
9. Chat History
Every conversation saves automatically. Sessions are organized by project name at:
%AppData%\OllamaVS\History\[ProjectName]\
Click the History button to browse saved sessions. Each entry shows the date and a preview. Click any session to reload it and continue the conversation where you left off.
10. Git Integration
Click the Git button in the chat panel header. Git must be installed and accessible from the command line.
	Option
	What It Does

	Generate Commit Message
	Reads staged and unstaged changes, generates a formatted commit message with subject line and bullet-point details.

	Summarize Changes
	Reads recent commit log and uncommitted changes, writes a plain-English summary of what changed.



TIP  Stage your changes with git add before generating a commit message for the most accurate result.
11. Error Window Integration
When your project has build errors, click Fix Errors in the chat panel header. The extension reads the error list from Visual Studio, finds the relevant code around each error, and sends everything to the AI. The AI responds with corrected code.
WARNING  For projects with many cascading errors, fix the first error and rebuild before fixing others. Many errors disappear once the root cause is corrected.
12. Multi-Model Routing
PERSONAL & PRO  Multi-model routing is available in Personal and Pro editions.
Automatically use different AI models for different task types. Set up once and the extension routes each request to the right model automatically.
	Task Type
	What Uses It

	Default (Chat)
	General conversation, git, error fixing

	Code Model
	Code generation, test generation, refactoring proposals

	Reasoning Model
	Debugging, code review, complex analysis

	Completion Model
	Inline completions — use a fast, small model here for speed



Configure in Tools > Options > Ollama AI > Model Routing. Leave any field blank to fall back to the default model.
13. Refactoring Engine
PERSONAL & PRO  The refactoring engine is available in Personal and Pro editions.
Analyzes your code and produces a list of concrete improvement proposals, each with the exact before and after code. Review each proposal and accept or reject individually.
13.1 Analyzing a File
Open the file you want to refactor.
Right-click and select Ask Ollama: Refactor Analysis.
The Refactoring Proposals window opens with proposals on the left.
Click any proposal to see the before/after diff on the right.
Click Apply This Change to open Diff View and accept or reject.
13.2 Refactoring Window Controls
	Control
	Function

	Proposal list
	All proposals with title, file, and category.

	Before / After panels
	Side-by-side diff of the proposed change.

	Apply This Change
	Opens Diff View for the selected proposal.

	Skip
	Mark as skipped and move to the next.

	Apply All
	Step through all remaining proposals in sequence.

	Export Report
	Save a markdown report of all proposals to your Desktop.



13.3 Solution-Wide Analysis
PRO ONLY  Solution-wide architectural analysis is available in the Pro edition only.
Select Solution Analysis from the Refactor menu to analyze all source files for structural problems: tight coupling, missing abstractions, oversized files, and cross-cutting duplication.
14. Test Generation
PERSONAL & PRO  Test generation is available in Personal and Pro editions.
Generates complete unit test classes from your existing code. Detects your test framework automatically (NUnit, xUnit, MSTest) and produces tests covering the happy path, edge cases, null inputs, and expected exceptions.
14.1 Generate Tests for a File
Open the source file.
Right-click and select Ask Ollama: Generate Tests for This File.
Review the generated test class in the chat response.
Click Insert Code at Cursor and review in Diff View before accepting.
14.2 Generate Tests for a Method
Select the method in the editor.
Right-click and select Ask Ollama: Generate Tests for Selection.
14.3 What Gets Generated
Complete test class with correct namespace and using statements
One test method per code path in the target code
Descriptive test names explaining exactly what is being tested
Happy path, edge cases, null inputs, and boundary conditions
Exception tests using the correct framework assertion syntax
Brief comment above each test explaining its purpose
15. Documentation Generation
PRO ONLY  Documentation generation is available in the Pro edition only.
Generates XML documentation comments for your code. Supports VB.NET triple-quote comments and C# triple-slash comments.
15.1 Document a File
Open the file.
Right-click and select Ask Ollama: Generate Documentation.
The AI adds documentation to every public class, method, function, sub, and property.
Review in Diff View and accept.
NOTE  Documentation generation only adds comments to public members. It never changes your code logic. Existing comments are preserved.
15.2 Document a Selection
Select a method, class, or property.
Right-click and select Ask Ollama: Generate Documentation.
Insert the generated comment block above the member.
15.3 Generate a README
Select Generate README from the Docs menu. The extension reads all source files and generates a README.md for your solution.
15.4 Documentation Coverage Report
Select Check Doc Coverage. The extension reports how many public members have documentation comments versus how many are missing them.
16. AI Code Review
PERSONAL & PRO  Code review is available in Personal and Pro editions.
Reviews your code for bugs, security issues, missing error handling, performance problems, and style inconsistencies.
16.1 Review Categories
	Category
	Contents

	CRITICAL
	Bugs, null reference exceptions, security vulnerabilities, data loss risks, unhandled crashes.

	WARNING
	Missing error handling, resource leaks, performance problems, race conditions, dead code.

	SUGGESTION
	Code duplication, long methods, unclear names, missing documentation.

	POSITIVE
	Well-written sections and good patterns worth noting.



16.2 Review a File or Selection
Right-click and select Ask Ollama: Review Code. The AI produces a structured review organized by severity.
16.3 Auto-Review on Commit
When enabled in settings, the extension monitors your git repository and automatically triggers a review whenever a commit is detected. The review appears in the chat panel.
Enable in Tools > Options > Ollama AI > Code Review > Auto Review on Commit = True.
17. Settings Reference
All settings are in Tools > Options > Ollama AI.
Provider
	Setting
	Description

	AI Provider
	Ollama, OpenAI, Anthropic, or OpenAI-Compatible.

	API Key
	Required for OpenAI and Anthropic. Leave blank for Ollama.



Server
	Setting
	Description

	Server URL
	Base URL of your server. Required for Ollama and OpenAI-Compatible.



Model
	Setting
	Description

	Model Name
	Default model for all tasks.

	Temperature
	0.0 = deterministic. 1.0 = creative. 0.1–0.3 recommended for code.

	Max Tokens
	Maximum response length. 4096 default.

	Enable Thinking Mode
	Extended reasoning for supported models such as DeepSeek-R1.

	Top P / Top K / Repeat Penalty
	Fine-tuning options. Ollama only.



Performance (Ollama only)
	Setting
	Description

	GPU Layers
	-1 = all layers on GPU. Lower if out-of-memory errors occur.

	CPU Threads
	-1 = auto. Set manually for high core-count CPUs.

	Context Window Size
	Token window size. 8192 default.

	Keep Model in Memory
	-1 = keep loaded permanently. 0 = unload after each response.



Model Routing (Personal and Pro)
	Setting
	Description

	Code Model
	For generation, tests, refactoring. Blank = use default.

	Reasoning Model
	For debugging and review. Blank = use default.

	Completion Model
	For inline completions. Use a fast small model.



Data Chunker Pro (All Editions)
	Setting
	Description

	Export Folder Path
	Path to a Data Chunker Pro export folder containing index.json.

	Auto-Load on Solution Open
	Automatically load the export when a solution opens.

	Max Chunks in Context
	Maximum DCP chunks injected per message. Default: 5.



Team Memory (Pro only)
	Setting
	Description

	Enable Team Shared Memory
	Turn team memory on or off.

	Storage Type
	NetworkPath or GitRepository.

	Team Network Path
	UNC path to the shared memory folder.

	Team Git Memory File
	Path relative to solution root for the git-committed memory file.



Code Review (Personal and Pro)
	Setting
	Description

	Auto Review on Commit
	Automatically review when a git commit is detected.

	Review Severity Filter
	All, WarningAndAbove, or CriticalOnly.



18. Tips for Best Results
18.1 Writing Good Prompts
Be specific. Describe the actual problem, not just where it is.
Paste error messages and stack traces directly into the chat.
Select the specific code you want to discuss before sending.
Ask the AI to explain its changes. Follow up if anything is unclear.
Use New Chat when switching to a completely different task.
18.2 Getting the Most From Data Chunker Pro
Export your entire codebase before starting a session on a large project.
Use Context-Aware chunking for source code for the best retrieval quality.
Set a default export path in settings so it loads automatically every session.
Re-export after major refactoring so the AI has current knowledge.
For projects with compiled binaries or no source, DCP extracts far more than the built-in RAG.
18.3 Model Selection
Code-specific models (devstral, qwen2.5-coder) are best for writing and fixing code.
Reasoning models (DeepSeek-R1, o1) are best for complex debugging and architecture.
Smaller models respond faster. Use a small model for completions, large for review.
19. Troubleshooting
	Problem
	Solution

	Red dot — cannot reach server
	Check the server address in settings. Open http://YOUR_ADDRESS:11434/api/tags in a browser to verify Ollama is running.

	Model not found
	The model name must match exactly. Run ollama list on the server and copy the exact name including the tag.

	Free edition response cut off
	Expected behaviour. Upgrade to Personal or Pro for unlimited response length.

	DCP loads 0 chunks
	Verify you are selecting the main export folder that contains index.json, not the Contents_ subfolder.

	DCP button not visible
	Check that Visibility is set to Visible in OllamaChatWindowControl.xaml on the BtnDataChunker element.

	Inline completions not appearing
	Wait a few seconds after opening a file. Try Ctrl+Space explicitly.

	Memory bank not updating
	Use File > Close Solution rather than closing Visual Studio with the X button.

	Git features not working
	Verify git is installed by running git --version in a command prompt.

	Auto-review triggering too often
	Set Review Severity Filter to CriticalOnly or disable Auto Review on Commit.



Quick Reference
Keyboard Shortcuts
	Shortcut
	Action

	Enter
	Send message

	Shift+Enter
	New line in input without sending

	Ctrl+Space
	Invoke AI inline completion

	Tab or Enter
	Accept completion suggestion

	Escape
	Dismiss completion list



Chat Panel Header Buttons
	Button
	Action

	Model dropdown
	Switch AI model instantly

	New Chat
	Clear conversation and start fresh

	Settings gear
	Open Tools > Options > Ollama AI

	Stop
	Cancel current response

	Git
	Commit message and change summary

	Fix Errors
	Send build errors to the AI

	Memory
	View or add to project memory bank

	History
	Browse and reload past sessions

	DCP
	Load Data Chunker Pro export (all editions)
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